Improvado EU - Access to Improvado data storage is stopped due to an ongoing maintenance – Incident details

All systems operational

Access to Improvado data storage is stopped due to an ongoing maintenance

Resolved
Major outage
Started 3 months agoLasted about 5 hours

Affected

Improvado Platform

Major outage from 8:04 PM to 1:17 AM

AI Agent

Major outage from 8:04 PM to 1:17 AM

Data Extraction

Major outage from 8:04 PM to 1:17 AM

Data Sources

Major outage from 8:04 PM to 1:17 AM

Facebook

Major outage from 8:04 PM to 1:17 AM

Google Universal Analytics

Major outage from 8:04 PM to 1:17 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Access will be restored after 3-3.5 hours